#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<figure>[\s\S]*<img([^>]+)>[\s\S]*<figcaption>([^>]+)[\s\S]*<\/figcaption>[\s\S]*<\/figure>"
Local $sString = "<figure>" & @CRLF & _
" <img src="/media/cc0-images/elephant-660-480.jpg"" & @CRLF & _
" alt="Elephant at sunset">" & @CRLF & _
" <figcaption>An elephant at sunset</figcaption>" & @CRLF & _
"</figure>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")