const regex = /<figure>[\s\S]*<img([^>]+)>[\s\S]*<figcaption>([^>]+)[\s\S]*<\/figcaption>[\s\S]*<\/figure>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<figure>[\\s\\S]*<img([^>]+)>[\\s\\S]*<figcaption>([^>]+)[\\s\\S]*<\\\/figcaption>[\\s\\S]*<\\\/figure>', 'gm')
const str = `<figure>
<img src="/media/cc0-images/elephant-660-480.jpg"
alt="Elephant at sunset">
<figcaption>An elephant at sunset</figcaption>
</figure>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}