$re = '/<figure>[\s\S]*<img([^>]+)>[\s\S]*<figcaption>([^>]+)[\s\S]*<\/figcaption>[\s\S]*<\/figure>/m';
$str = '<figure>
<img src="/media/cc0-images/elephant-660-480.jpg"
alt="Elephant at sunset">
<figcaption>An elephant at sunset</figcaption>
</figure>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);