use strict;
my $str = 'A1A1A1A1A1A1A1A1 --> should match
12222222222222DE --> should match
\'PRODUKT\', \'PRODUKT\', \'NICKNAME\', \'PRODUKTNAME\' --> shouldn\'t match any of this but its matching
123456 --> should match
6203-5458 --> shouldn\'t match
234SS-4NNNAA --> should match';
my $regex = qr/(?<![\dA-Z-])(?=[\dA-Z-]{6,})(?:[\d-]+[A-Z]|[A-Z-]+\d)[A-Z\d-]*|[0-9]{6,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}