re = /(?<![\dA-Z-])(?=[\dA-Z-]{6,})(?:[\d-]+[A-Z]|[A-Z-]+\d)[A-Z\d-]*|[0-9]{6,}/m
str = 'A1A1A1A1A1A1A1A1 --> should match
12222222222222DE --> should match
\'PRODUKT\', \'PRODUKT\', \'NICKNAME\', \'PRODUKTNAME\' --> shouldn\'t match any of this but its matching
123456 --> should match
6203-5458 --> shouldn\'t match
234SS-4NNNAA --> should match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end