$re = '/(?<![\dA-Z-])(?=[\dA-Z-]{6,})(?:[\d-]+[A-Z]|[A-Z-]+\d)[A-Z\d-]*|[0-9]{6,}/m';
$str = 'A1A1A1A1A1A1A1A1 --> should match
12222222222222DE --> should match
\'PRODUKT\', \'PRODUKT\', \'NICKNAME\', \'PRODUKTNAME\' --> shouldn\'t match any of this but its matching
123456 --> should match
6203-5458 --> shouldn\'t match
234SS-4NNNAA --> should match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);