import re
regex = re.compile(r"([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z]{2,4})", flags=re.MULTILINE)
test_str = ("JakobCJakobsen@einrot.com+1 (845) 858-7707\n"
"johndoe@email.com1234567890\n"
"304-438-2648SandraCTaylor@dayrep.com\n"
"978-243-8596JuanPerez@teleworm.us\n"
"413-259-3637BuiQuynhChan@fleckens.hu\n"
"AlexCrawford@dayrep.com+1 (208) 264-9063\n"
"StefanijaNovosel@teleworm.us1 518 487 4865")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")