$re = '`^[^:/]*[:/](*SKIP)(*F)|.+`m';
$str = 'small_animal/Mouse
BigAnimal:Elephant
Not an animal.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);