const regex = /^word(?!.*unique).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^word(?!.*unique).*', 'gm')
const str = `Есть, например, вот такие строки:
word-любой-текст-здесь-без-слова
word-любой-текст-но-есть-слово-unique-любой-текст
word-другой-любой-текст
word-ещё-один-другой-любой-текст-но-со-словом-unique-и-дальше-любой-текст
Как написать регулярное выражение, чтобы выбрать строки, начинающиеся на слово word, но в которых нет слова unique (т.е. должны быть выбраны строки 1 и 3)? `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}