import Foundation
let pattern = #"^word(?!.*unique).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Есть, например, вот такие строки:
word-любой-текст-здесь-без-слова
word-любой-текст-но-есть-слово-unique-любой-текст
word-другой-любой-текст
word-ещё-один-другой-любой-текст-но-со-словом-unique-и-дальше-любой-текст
Как написать регулярное выражение, чтобы выбрать строки, начинающиеся на слово word, но в которых нет слова unique (т.е. должны быть выбраны строки 1 и 3)?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)