re = /^word(?!.*unique).*/m
str = 'Есть, например, вот такие строки:
word-любой-текст-здесь-без-слова
word-любой-текст-но-есть-слово-unique-любой-текст
word-другой-любой-текст
word-ещё-один-другой-любой-текст-но-со-словом-unique-и-дальше-любой-текст
Как написать регулярное выражение, чтобы выбрать строки, начинающиеся на слово word, но в которых нет слова unique (т.е. должны быть выбраны строки 1 и 3)? '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end