re = /^\t\S.*/m
str = 'This is aciton
Two tab
One tabdialog
This is aciton
Two tab
Second tabdialog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end