#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\b[A-Z]{2,3}\s*[$€£¥₣₹]?|[$€£¥₣₹])\s*\d+(?:\.\d+)?(?:\s*(?:K|[BM](?:illions?)?)\b)?"
Local $sString = "Company Fragile9 Closes €9M Series B Funding" & @CRLF & _
"Appplle21 Receives CAD$17.5K in Equity Financing" & @CRLF & _
"Cat Raises $10.8 Millions in Series A Funding" & @CRLF & _
"Sun Raises EUR35M in Funding at a $1 Billion Valuation" & @CRLF & _
"Japan1337 Announces JPY 1.78 Billion Funding Round"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")