import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b[A-Z]{2,3}\\s*[$€£¥₣₹]?|[$€£¥₣₹])\\s*\\d+(?:\\.\\d+)?(?:\\s*(?:K|[BM](?:illions?)?)\\b)?";
final String string = "Company Fragile9 Closes €9M Series B Funding\n"
+ "Appplle21 Receives CAD$17.5K in Equity Financing\n"
+ "Cat Raises $10.8 Millions in Series A Funding\n"
+ "Sun Raises EUR35M in Funding at a $1 Billion Valuation\n"
+ "Japan1337 Announces JPY 1.78 Billion Funding Round";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}