$re = '/(?:\b[A-Z]{2,3}\s*[$€£¥₣₹]?|[$€£¥₣₹])\s*\d+(?:\.\d+)?(?:\s*(?:K|[BM](?:illions?)?)\b)?/m';
$str = 'Company Fragile9 Closes €9M Series B Funding
Appplle21 Receives CAD$17.5K in Equity Financing
Cat Raises $10.8 Millions in Series A Funding
Sun Raises EUR35M in Funding at a $1 Billion Valuation
Japan1337 Announces JPY 1.78 Billion Funding Round';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);