#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\w.]"
Local $sString = "adb@yu.com" & @CRLF & _
"ads§mnm.com" & @CRLF & _
"vbnÖss.com" & @CRLF & _
"ddУrr.com" & @CRLF & _
"weίsd.com" & @CRLF & _
"ftΞvg.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")