package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\w.]`)
var str = `adb@yu.com
ads§mnm.com
vbnÖss.com
ddУrr.com
weίsd.com
ftΞvg.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}