$re = '/[^\w.]/m';
$str = 'adb@yu.com
ads§mnm.com
vbnÖss.com
ddУrr.com
weίsd.com
ftΞvg.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);