package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<code>\S+)\s+(?<name>.*?)\s+(?<num>\$\d[\d.]*)\s*(?<details>.*)$`)
var str = `BK0001 My book (4th Edition) $49.95 (Clearance Price!)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}