re = /^(?<code>\S+)\s+(?<name>.*?)\s+(?<num>\$\d[\d.]*)\s*(?<details>.*)$/m
str = 'BK0001 My book (4th Edition) $49.95 (Clearance Price!)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end