const regex = /^(?<code>\S+)\s+(?<name>.*?)\s+(?<num>\$\d[\d.]*)\s*(?<details>.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<code>\\S+)\\s+(?<name>.*?)\\s+(?<num>\\$\\d[\\d.]*)\\s*(?<details>.*)$', 'gm')
const str = `BK0001 My book (4th Edition) \$49.95 (Clearance Price!)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}