using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^0-9])0+";
string substitution = @"";
string input = @"0000001000245";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}