const regex = /(^|[^0-9])0+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^0-9])0+', 'g')
const str = `0000001000245`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);