$re = '/(^|[^0-9])0+/';
$str = '0000001000245';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;