$re = '/.*"(.*?)sources/m';
$str = 'setAttr ".ftn" -type "string" "C:/Users/Steven/Desktop/Project/sources/foobar.jpg";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);