re = /.*"(.*?)sources/m
str = 'setAttr ".ftn" -type "string" "C:/Users/Steven/Desktop/Project/sources/foobar.jpg";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end