using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http|https):\/\/www.example\.com\/holidays\/(.*)-holidays\.html";
string input = @"https://www.example.com/halkidiki-holidays.html
https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html
https://www.example.com/holidays/abano-terme-holidays.html
https://www.example.com/holidays/crete/hersonissos/hotel-lovely-holidays.html
https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html
https://www.example.com/halkidiki-holidays.html
https://www.example.com/holidays/abano%20terme-holidays.html
https://www.example.com/holidays/abano-terme-holidays.html
https://www.example.com/holidays/abu-dhabi-all-inclusive-holidays.html
https://www.example.com/holidays/abu-dhabi-holidays.html
https://www.example.com/holidays/abu-soma-holidays.html
https://www.example.com/holidays/acharavi-holidays.html
https://www.example.com/holidays/achladies-holidays.html
https://www.example.com/holidays/aci-castello-holidays.html
https://www.example.com/holidays/acireale-holidays.html
https://www.example.com/holidays/acoteias-holidays.html
https://www.example.com/holidays/adana-holidays.html
https://www.example.com/holidays/adelianos-kampos-holidays.html
https://www.example.com/holidays/aegean-coast-holidays.html
https://www.example.com/holidays/afandou-holidays.html
https://www.example.com/holidays/afitos-holidays.html
https://www.example.com/holidays/africa-holidays.html
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}