use strict;
my $str = 'https://www.example.com/halkidiki-holidays.html
https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html
https://www.example.com/holidays/abano-terme-holidays.html
https://www.example.com/holidays/crete/hersonissos/hotel-lovely-holidays.html
https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html
https://www.example.com/halkidiki-holidays.html
https://www.example.com/holidays/abano%20terme-holidays.html
https://www.example.com/holidays/abano-terme-holidays.html
https://www.example.com/holidays/abu-dhabi-all-inclusive-holidays.html
https://www.example.com/holidays/abu-dhabi-holidays.html
https://www.example.com/holidays/abu-soma-holidays.html
https://www.example.com/holidays/acharavi-holidays.html
https://www.example.com/holidays/achladies-holidays.html
https://www.example.com/holidays/aci-castello-holidays.html
https://www.example.com/holidays/acireale-holidays.html
https://www.example.com/holidays/acoteias-holidays.html
https://www.example.com/holidays/adana-holidays.html
https://www.example.com/holidays/adelianos-kampos-holidays.html
https://www.example.com/holidays/aegean-coast-holidays.html
https://www.example.com/holidays/afandou-holidays.html
https://www.example.com/holidays/afitos-holidays.html
https://www.example.com/holidays/africa-holidays.html
';
my $regex = qr/(http|https):\/\/www.example\.com\/holidays\/(.*)-holidays\.html/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}