# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http|https):\/\/www.example\.com\/holidays\/(.*)-holidays\.html"
test_str = ("https://www.example.com/halkidiki-holidays.html\n"
"https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html\n"
"https://www.example.com/holidays/abano-terme-holidays.html\n"
"https://www.example.com/holidays/crete/hersonissos/hotel-lovely-holidays.html\n"
"https://www.example.com/blog/recommendations/holiday-hotspots/where-is-hot-in-march/holidays/all-inclusive-holidays.html\n"
"https://www.example.com/halkidiki-holidays.html\n"
"https://www.example.com/holidays/abano%20terme-holidays.html\n"
"https://www.example.com/holidays/abano-terme-holidays.html\n"
"https://www.example.com/holidays/abu-dhabi-all-inclusive-holidays.html\n"
"https://www.example.com/holidays/abu-dhabi-holidays.html\n"
"https://www.example.com/holidays/abu-soma-holidays.html\n"
"https://www.example.com/holidays/acharavi-holidays.html\n"
"https://www.example.com/holidays/achladies-holidays.html\n"
"https://www.example.com/holidays/aci-castello-holidays.html\n"
"https://www.example.com/holidays/acireale-holidays.html\n"
"https://www.example.com/holidays/acoteias-holidays.html\n"
"https://www.example.com/holidays/adana-holidays.html\n"
"https://www.example.com/holidays/adelianos-kampos-holidays.html\n"
"https://www.example.com/holidays/aegean-coast-holidays.html\n"
"https://www.example.com/holidays/afandou-holidays.html\n"
"https://www.example.com/holidays/afitos-holidays.html\n"
"https://www.example.com/holidays/africa-holidays.html\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.