$re = '/^(\w+)[^@]*(@\r?\n\1.*|\r?\n\1.*@)$/mu';
$str = 'Причем, и официальная
заработная плата,
заработная плата,
и доход от деятельности самозанятого —
могут поступать на одну и ту же карту.
Для выражений того чтобы самозанятому
Для того чтобы самозанятому@
отчитываться перед налоговой,
никаких при этом деклараций выражений @
никаких деклараций
заполнять и подавать не нужно.
Эксперт перечислила порядок';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);