re = /^(\w+)[^@]*(@\r?\n\1.*|\r?\n\1.*@)$/m
str = 'Причем, и официальная
заработная плата,
заработная плата,
и доход от деятельности самозанятого —
могут поступать на одну и ту же карту.
Для выражений того чтобы самозанятому
Для того чтобы самозанятому@
отчитываться перед налоговой,
никаких при этом деклараций выражений @
никаких деклараций
заполнять и подавать не нужно.
Эксперт перечислила порядок'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end