# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\w+)[^@]*(@\r?\n\1.*|\r?\n\1.*@)$"
test_str = ("Причем, и официальная\n"
"заработная плата,\n"
"заработная плата,\n"
"и доход от деятельности самозанятого —\n"
"могут поступать на одну и ту же карту.\n"
"Для выражений того чтобы самозанятому\n"
"Для того чтобы самозанятому@\n"
"отчитываться перед налоговой,\n"
"никаких при этом деклараций выражений @\n"
"никаких деклараций\n"
"заполнять и подавать не нужно.\n"
"Эксперт перечислила порядок")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.