#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:\([^)]*\))*[^()\n]+[^@\n]*@)(?!(?:\([^)]*\))*\.)(?:(?:[\w!#$%&'*+/=?^`{|}~.-]|\([\w!#$%&'*+/=?^`{|}~.-]*\))+|"(?:[\w!#$%&'*+/=?^`{|}~.-]|\([\w!#$%&'*+/=?^`{|}~.-]*\))*")@(?:\([A-Za-z0-9-]*\))*(?:[A-Za-z0-9]+(?:(?:\([A-Za-z0-9-]*\))*-(?:\([A-Za-z0-9-]*\))*[A-Za-z0-9]+)*(?:\([A-Za-z0-9-]*\))*)(?:\.(?:\([A-Za-z0-9-]*\))*(?:[A-Za-z0-9]+(?:(?:\([A-Za-z0-9-]*\))*-(?:\([A-Za-z0-9-]*\))*[A-Za-z0-9]+)*(?:\([A-Za-z0-9-]*\))*))+$"
Local $sString = "************* VALID *************" & @CRLF & _
"a@a.a" & @CRLF & _
"-@a.a" & @CRLF & _
"a@1.a" & @CRLF & _
"a@a-a.a" & @CRLF & _
"a@a.a-a" & @CRLF & _
"!#$%&'*+-/=?^_`{|}~@test.jp" & @CRLF & _
"a..a@test.jp" & @CRLF & _
"a..@test.jp" & @CRLF & _
""a"@test.jp" & @CRLF & _
"""@test.jp" & @CRLF & _
"(comment)(comment)a(comment)(comment)(comment)@(comment)a.a" & @CRLF & _
"(comment)(comment)a.(comment)(comment)(comment)@(comment)a.a" & @CRLF & _
"(comment)(comment)a(comment).(comment)(comment)@(comment)a.a" & @CRLF & _
"a@(comment)a(comment)-(comment)a(comment).a" & @CRLF & _
"john.doe@(-comment)example.com" & @CRLF & _
"john.doe@example.com(comment-)" & @CRLF & _
"()a@test.jp" & @CRLF & _
"(a)a@test.jp" & @CRLF & _
"a(a)@test.jp" & @CRLF & _
"a@(a)test.jp" & @CRLF & _
"a@test.jp(a)" & @CRLF & _
"simple@example.com" & @CRLF & _
"very.common@example.com" & @CRLF & _
"disposable.style.email.with+symbol@example.com" & @CRLF & _
"other.email-with-hyphen@example.com" & @CRLF & _
"fully-qualified-domain@example.com" & @CRLF & _
"user.name+tag+sorting@example.com" & @CRLF & _
"x@example.com" & @CRLF & _
"example-indeed@strange-example.com" & @CRLF & _
"test/test@test.com" & @CRLF & _
"example@s.example" & @CRLF & _
""john..doe"@example.org" & @CRLF & _
"mailhost!username@example.org" & @CRLF & _
"user%example.com@example.org" & @CRLF & _
"user-@example.org" & @CRLF & _
"1@1234567890123456789012345678901234567890123456789012345678901234.1.2.3.4.5.6.7" & @CRLF & _
"a@a-a.a" & @CRLF & _
"a@a-a-a.a" & @CRLF & _
"a@a-a-a-a.a" & @CRLF & _
"a@a-a-a.a-a-a" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"************* INVALID *************" & @CRLF & _
"a@a" & @CRLF & _
"a@a." & @CRLF & _
"a@-a.a" & @CRLF & _
"a@a-.a" & @CRLF & _
"a@a.a-" & @CRLF & _
"a@a.-a" & @CRLF & _
"a;a@test.jp" & @CRLF & _
".a@test.jp" & @CRLF & _
"";"@test.jp" & @CRLF & _
""@"@test.jp" & @CRLF & _
""a@test.jp" & @CRLF & _
"a"@test.jp" & @CRLF & _
"a""@test.jp" & @CRLF & _
"""a@test.jp" & @CRLF & _
"()@test.jp" & @CRLF & _
")(a@test.jp" & @CRLF & _
"(a)@test.jp" & @CRLF & _
"(a@test.jp" & @CRLF & _
"(())a@test.jp" & @CRLF & _
"(comment)(comment).(comment)a(comment)(comment)@(comment)a.a" & @CRLF & _
"john.doe@(comment).com" & @CRLF & _
"a@(comment)a(comment)-(comment)(comment).a" & @CRLF & _
"Αθήνα@email.com" & @CRLF & _
"admin@mailserver1" & @CRLF & _
"" "@example.org" & @CRLF & _
""very.(),:;<>[]\".VERY.\"very@\\ \"very\".unusual"@strange.example.com" & @CRLF & _
"postmaster@[123.123.123.123]" & @CRLF & _
"postmaster@[IPv6:2001:0db8:85a3:0000:0000:8a2e:0370:7334]" & @CRLF & _
"a,a@a.a" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")