using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:\([^)]*\))*[^()\n]+[^@\n]*@)(?!(?:\([^)]*\))*\.)(?:(?:[\w!#$%&'*+/=?^`{|}~.-]|\([\w!#$%&'*+/=?^`{|}~.-]*\))+|""(?:[\w!#$%&'*+/=?^`{|}~.-]|\([\w!#$%&'*+/=?^`{|}~.-]*\))*"")@(?:\([A-Za-z0-9-]*\))*(?:[A-Za-z0-9]+(?:(?:\([A-Za-z0-9-]*\))*-(?:\([A-Za-z0-9-]*\))*[A-Za-z0-9]+)*(?:\([A-Za-z0-9-]*\))*)(?:\.(?:\([A-Za-z0-9-]*\))*(?:[A-Za-z0-9]+(?:(?:\([A-Za-z0-9-]*\))*-(?:\([A-Za-z0-9-]*\))*[A-Za-z0-9]+)*(?:\([A-Za-z0-9-]*\))*))+$";
string input = @"************* VALID *************
a@a.a
-@a.a
a@1.a
a@a-a.a
a@a.a-a
!#$%&'*+-/=?^_`{|}~@test.jp
a..a@test.jp
a..@test.jp
""a""@test.jp
""@test.jp
(comment)(comment)a(comment)(comment)(comment)@(comment)a.a
(comment)(comment)a.(comment)(comment)(comment)@(comment)a.a
(comment)(comment)a(comment).(comment)(comment)@(comment)a.a
a@(comment)a(comment)-(comment)a(comment).a
john.doe@(-comment)example.com
john.doe@example.com(comment-)
()a@test.jp
(a)a@test.jp
a(a)@test.jp
a@(a)test.jp
a@test.jp(a)
simple@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-hyphen@example.com
fully-qualified-domain@example.com
user.name+tag+sorting@example.com
x@example.com
example-indeed@strange-example.com
test/test@test.com
example@s.example
""john..doe""@example.org
mailhost!username@example.org
user%example.com@example.org
user-@example.org
1@1234567890123456789012345678901234567890123456789012345678901234.1.2.3.4.5.6.7
a@a-a.a
a@a-a-a.a
a@a-a-a-a.a
a@a-a-a.a-a-a
************* INVALID *************
a@a
a@a.
a@-a.a
a@a-.a
a@a.a-
a@a.-a
a;a@test.jp
.a@test.jp
"";""@test.jp
""@""@test.jp
""a@test.jp
a""@test.jp
a""@test.jp
""a@test.jp
()@test.jp
)(a@test.jp
(a)@test.jp
(a@test.jp
(())a@test.jp
(comment)(comment).(comment)a(comment)(comment)@(comment)a.a
john.doe@(comment).com
a@(comment)a(comment)-(comment)(comment).a
Αθήνα@email.com
admin@mailserver1
"" ""@example.org
""very.(),:;<>[]\"".VERY.\""very@\\ \""very\"".unusual""@strange.example.com
postmaster@[123.123.123.123]
postmaster@[IPv6:2001:0db8:85a3:0000:0000:8a2e:0370:7334]
a,a@a.a
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}