use strict;
my $str = '************* VALID *************
a@a.a
-@a.a
a@1.a
a@a-a.a
a@a.a-a
!#$%&\'*+-/=?^_`{|}~@test.jp
a..a@test.jp
a..@test.jp
"a"@test.jp
""@test.jp
(comment)(comment)a(comment)(comment)(comment)@(comment)a.a
(comment)(comment)a.(comment)(comment)(comment)@(comment)a.a
(comment)(comment)a(comment).(comment)(comment)@(comment)a.a
a@(comment)a(comment)-(comment)a(comment).a
john.doe@(-comment)example.com
john.doe@example.com(comment-)
()a@test.jp
(a)a@test.jp
a(a)@test.jp
a@(a)test.jp
a@test.jp(a)
simple@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-hyphen@example.com
fully-qualified-domain@example.com
user.name+tag+sorting@example.com
x@example.com
example-indeed@strange-example.com
test/test@test.com
example@s.example
"john..doe"@example.org
mailhost!username@example.org
user%example.com@example.org
user-@example.org
1@1234567890123456789012345678901234567890123456789012345678901234.1.2.3.4.5.6.7
a@a-a.a
a@a-a-a.a
a@a-a-a-a.a
a@a-a-a.a-a-a
************* INVALID *************
a@a
a@a.
a@-a.a
a@a-.a
a@a.a-
a@a.-a
a;a@test.jp
.a@test.jp
";"@test.jp
"@"@test.jp
"a@test.jp
a"@test.jp
a""@test.jp
""a@test.jp
()@test.jp
)(a@test.jp
(a)@test.jp
(a@test.jp
(())a@test.jp
(comment)(comment).(comment)a(comment)(comment)@(comment)a.a
john.doe@(comment).com
a@(comment)a(comment)-(comment)(comment).a
Αθήνα@email.com
admin@mailserver1
" "@example.org
"very.(),:;<>[]\\".VERY.\\"very@\\\\ \\"very\\".unusual"@strange.example.com
postmaster@[123.123.123.123]
postmaster@[IPv6:2001:0db8:85a3:0000:0000:8a2e:0370:7334]
a,a@a.a
';
my $regex = qr/^(?=(?:\([^)]*\))*[^()\n]+[^@\n]*@)(?!(?:\([^)]*\))*\.)(?:(?:[\w!#$%&'*+/=?^`{|}~.-]|\([\w!#$%&'*+/=?^`{|}~.-]*\))+|"(?:[\w!#$%&'*+/=?^`{|}~.-]|\([\w!#$%&'*+/=?^`{|}~.-]*\))*")@(?:\([A-Za-z0-9-]*\))*(?:[A-Za-z0-9]+(?:(?:\([A-Za-z0-9-]*\))*-(?:\([A-Za-z0-9-]*\))*[A-Za-z0-9]+)*(?:\([A-Za-z0-9-]*\))*)(?:\.(?:\([A-Za-z0-9-]*\))*(?:[A-Za-z0-9]+(?:(?:\([A-Za-z0-9-]*\))*-(?:\([A-Za-z0-9-]*\))*[A-Za-z0-9]+)*(?:\([A-Za-z0-9-]*\))*))+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}