using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)^(?<date>\w+\s\d+)\s+(?<Time>\d+:\d+:\d+).*defaultMsg\"":\""(?<defaultMsg>[^\""]+).*userName\"":\""(?<userName>[^\""]+)";
string input = @"Aug 25 17:41:951 IP_ADDR consolidated_audit: {""affectedEntityList"": [{""entityType"":""vm"",""name"":""hostname | serverpurpose"",""uuid"":""Ilaef477-6f03-4a22-baa7-23736c8e741c""}],""alertUid"":""VmUpdateAudit"",""classificationList"":[""UserAction""],""creationTimestampUsecs"": ""1629874233889978"",[""defaultMsg"":""Updated VM hostname serverpurpose"",""opEndTimestampUsecs"",""1629874233884373"",""opStartTimestampUsecs"",""1629874233779524"",""operationType"";""Update"",""originatingClusterUuid"":""0005ad50-f430-a46c-001e-e4434bb76b0e"",""params"":{""is_secure_boot"":""false"",""is_uefi_boot"":""true"",""vm_name"":""hostname | serverpurpose""}, ""recordType"": ""Audit"",""severity"":""Audit"",""userName"":""abc@abc.com"",""userUuid"":""3f73d040-7516-5caa-a956-91179b2cblf5"",""uuid"":""254f3952-bf9b-4205-8al4-ad2074ed70ab""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}