# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?ms)^(?<date>\w+\s\d+)\s+(?<Time>\d+:\d+:\d+).*defaultMsg\":\"(?<defaultMsg>[^\"]+).*userName\":\"(?<userName>[^\"]+)"
test_str = "Aug 25 17:41:951 IP_ADDR consolidated_audit: {\"affectedEntityList\": [{\"entityType\":\"vm\",\"name\":\"hostname | serverpurpose\",\"uuid\":\"Ilaef477-6f03-4a22-baa7-23736c8e741c\"}],\"alertUid\":\"VmUpdateAudit\",\"classificationList\":[\"UserAction\"],\"creationTimestampUsecs\": \"1629874233889978\",[\"defaultMsg\":\"Updated VM hostname serverpurpose\",\"opEndTimestampUsecs\",\"1629874233884373\",\"opStartTimestampUsecs\",\"1629874233779524\",\"operationType\";\"Update\",\"originatingClusterUuid\":\"0005ad50-f430-a46c-001e-e4434bb76b0e\",\"params\":{\"is_secure_boot\":\"false\",\"is_uefi_boot\":\"true\",\"vm_name\":\"hostname | serverpurpose\"}, \"recordType\": \"Audit\",\"severity\":\"Audit\",\"userName\":\"abc@abc.com\",\"userUuid\":\"3f73d040-7516-5caa-a956-91179b2cblf5\",\"uuid\":\"254f3952-bf9b-4205-8al4-ad2074ed70ab\"}"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.