package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|\s)\w*?[aeiou]\w*`)
var str = `example
this sentence is bad
ths sntnc k
<:example:1234567890>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}