re = /(?:^|\s)\w*?[aeiou]\w*/m
str = 'example
this sentence is bad
ths sntnc k
<:example:1234567890>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end