$re = '/(?:^|\s)\w*?[aeiou]\w*/m';
$str = 'example
this sentence is bad
ths sntnc k
<:example:1234567890>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);