# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.\w+$/m$0/gm;t' <<< "http://example.com/comic1.jpg"