$re = '/\.\w+$/m';
$str = 'http://example.com/comic1.jpg';
$subst = "m$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;