use strict;
my $str = 'http://example.com/comic1.jpg';
my $regex = qr/\.\w+$/mp;
my $subst = 'm$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";