import re
regex = re.compile(r"^[a-zA-Z0-9](?:[a-zA-Z0-9 ._-]*[a-zA-Z0-9])?\.[a-zA-Z0-9_-]+$", flags=re.MULTILINE)
test_str = ("## BELOW SHOULD MATCH\n"
"web.config\n"
"httpd.conf\n"
"test.txt\n"
"1.1\n"
"my long file name.txt\n\n"
"## BELOW SHOULD NOT MATCH\n"
"æøå.txt\n"
"hosts\n"
".gitignore\n"
".htaccess\n"
"test.t xt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")