// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9](?:[a-zA-Z0-9 ._-]*[a-zA-Z0-9])?\.[a-zA-Z0-9_-]+$").unwrap();
let string = "## BELOW SHOULD MATCH
web.config
httpd.conf
test.txt
1.1
my long file name.txt
## BELOW SHOULD NOT MATCH
æøå.txt
hosts
.gitignore
.htaccess
test.t xt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}