#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(\{\{client\.events\.(?:purchase|(add_to_cart))(?:\.\d)?\.(.*)\}\})"
Local $sString = "ou recently ... {{client.events.add_to_cart.product_name}}, ..." & @CRLF & _
"" & @CRLF & _
".." & @CRLF & _
"" & @CRLF & _
"Also" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
"" & @CRLF & _
"{{client.events.purchase.product_name}}" & @CRLF & _
"" & @CRLF & _
"{{client.events.add_to_cart.product_name}}" & @CRLF & _
"{{client.events.add_to_cart.0.product_name}}" & @CRLF & _
"{{client.events.add_to_cart.1.product_name}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")