use strict;
my $str = 'ou recently ... {{client.events.add_to_cart.product_name}}, ...
..
Also
...
{{client.events.purchase.product_name}}
{{client.events.add_to_cart.product_name}}
{{client.events.add_to_cart.0.product_name}}
{{client.events.add_to_cart.1.product_name}}';
my $regex = qr/(\{\{client\.events\.(?:purchase|(add_to_cart))(?:\.\d)?\.(.*)\}\})/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}