const regex = /(\{\{client\.events\.(?:purchase|(add_to_cart))(?:\.\d)?\.(.*)\}\})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\{\\{client\\.events\\.(?:purchase|(add_to_cart))(?:\\.\\d)?\\.(.*)\\}\\})', 'gmi')
const str = `ou recently ... {{client.events.add_to_cart.product_name}}, ...
..
Also
...
{{client.events.purchase.product_name}}
{{client.events.add_to_cart.product_name}}
{{client.events.add_to_cart.0.product_name}}
{{client.events.add_to_cart.1.product_name}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}