#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((ftp|http|https):\/\/)?(www.)?(?!.*(ftp|http|https|www.))[a-zA-Z0-9_-]+(\.[a-zA-Z]+)+((\/)[\w#]+)*(\/\w+\?[a-zA-Z0-9_]+=\w+(&[a-zA-Z0-9_]+=\w+)*)?$"
Local $sString = "http://www.sample.com" & @CRLF & _
"https://www.sample.com" & @CRLF & _
"http://www.sample.com/xyz" & @CRLF & _
"www.sample.com" & @CRLF & _
"www.sample.com/xyz/#/xyz" & @CRLF & _
"sample.com" & @CRLF & _
"www.sample.com" & @CRLF & _
"mofiz.com" & @CRLF & _
"kolim.com" & @CRLF & _
"www.murikhao.www.sample.com" & @CRLF & _
"http://murihao.www.sample.com" & @CRLF & _
"http://www.sample.com/xyz?abc=dkd&p=q&c=2" & @CRLF & _
"www.sample.gov.bd" & @CRLF & _
"www.sample.com.en" & @CRLF & _
"www.sample.vu" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")