import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((ftp|http|https):\\/\\/)?(www.)?(?!.*(ftp|http|https|www.))[a-zA-Z0-9_-]+(\\.[a-zA-Z]+)+((\\/)[\\w#]+)*(\\/\\w+\\?[a-zA-Z0-9_]+=\\w+(&[a-zA-Z0-9_]+=\\w+)*)?$";
final String string = "http://www.sample.com\n"
+ "https://www.sample.com\n"
+ "http://www.sample.com/xyz\n"
+ "www.sample.com\n"
+ "www.sample.com/xyz/#/xyz\n"
+ "sample.com\n"
+ "www.sample.com\n"
+ "mofiz.com\n"
+ "kolim.com\n"
+ "www.murikhao.www.sample.com\n"
+ "http://murihao.www.sample.com\n"
+ "http://www.sample.com/xyz?abc=dkd&p=q&c=2\n"
+ "www.sample.gov.bd\n"
+ "www.sample.com.en\n"
+ "www.sample.vu\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}